All systems operational

RSA Maintenance Update

Completed
Scheduled for April 22, 2024 at 9:30:00 PM – 11:30:00 PM

Affects

Core Services
Citrix - BCC Portal
RSA - Two Factor Authentication
Updates
  • Completed
    April 22, 2024 at 11:30:00 PM
    Completed
    April 22, 2024 at 11:30:00 PM
    Maintenance has completed successfully
  • In progress
    April 22, 2024 at 9:30:01 PM
    In progress
    April 22, 2024 at 9:30:01 PM
    Maintenance is now in progress
  • Planned
    April 22, 2024 at 9:30:00 PM
    Planned
    April 22, 2024 at 9:30:00 PM

    We are planning for a scheduled maintenance during that time.

    During this time it will not be possible to to log in to Citrix