Resolved
BCC Citrix - Incident

Started
July 19, 2021 at 8:59:40 AM GMT+00:00
Status
Resolved after about 23 hours
Affected
Core Services
Citrix - BCC Portal

Impact

Degraded performance
  • Resolved
    July 20, 2021 at 7:29:38 AM GMT+00:00

    Maintenance has been performed successfully, and services performance has been restored.

    BCC IT

  • Investigating
    July 19, 2021 at 8:59:40 AM GMT+00:00

    We are currently experiencing a performance degradation on Citrix affecting user logons. We are investigating the issue and will update communicate through this incident.

    BCC IT