Completed
Citrix Maintenance

Starts
March 14, 2022 at 8:00:00 PM GMT+00:00
Status
Resolved after about 1 month
Affects
Core Services
Citrix - BCC Portal
  • Completed
    April 20, 2022 at 9:27:05 AM GMT+00:00

    Maintenance has completed successfully.

  • Planned
    March 14, 2022 at 8:00:00 PM GMT+00:00

    We are planning for a scheduled maintenance during that time.