Completed
BCC password selfservice portal

Starts
February 22, 2022 at 3:00:00 PM GMT+00:00
Status
Resolved after about 1 hour
Affects
Core Services
BCC Password Self Service
  • Completed
    February 22, 2022 at 4:00:01 PM GMT+00:00

    Maintenance has completed successfully

  • In progress
    February 22, 2022 at 3:00:01 PM GMT+00:00

    Maintenance is now in progress

  • In progress
    February 22, 2022 at 3:00:01 PM GMT+00:00

    Maintenance is now in progress

  • In progress
    February 22, 2022 at 3:00:01 PM GMT+00:00

    Maintenance is now in progress

  • Planned
    February 22, 2022 at 3:00:00 PM GMT+00:00

    AD selfservice portal is to be upgraded. The portal may be unavailable at this time