Completed
Citrix Maintenance

Status
Resolved after about 4 hours
Started
April 28, 2022 at 6:30:00 PM GMT+00:00
Completed
May 01, 2022 at 3:10:00 AM GMT+00:00
Affects
Core Services
Citrix - BCC Portal
  • Completed
    April 28, 2022 at 10:30:00 PM GMT+00:00

    Maintenance has completed successfully

  • Planned
    April 28, 2022 at 6:30:00 PM GMT+00:00

    We are planning for a scheduled maintenance during that time.

  • In progress
    April 26, 2022 at 1:49:42 PM GMT+00:00

    Due to connectivity maintenance will be taking place on Tuesday 26/04/2022 at 7:30pm.