Completed
BCC Password Self Service

Status
Resolved after about 1 hour
Started
May 03, 2022 at 7:00:00 PM GMT+00:00
Completed
May 03, 2022 at 8:00:00 PM GMT+00:00
Affects
Core Services
BCC Password Self Service
  • Update
    May 03, 2022 at 8:00:00 PM GMT+00:00

    Maintenance has completed successfully

  • Update
    May 03, 2022 at 8:00:00 PM GMT+00:00

    Maintenance has completed successfully

  • Completed
    May 03, 2022 at 8:00:00 PM GMT+00:00

    Maintenance has completed successfully

  • In progress
    May 03, 2022 at 7:00:01 PM GMT+00:00

    Maintenance is now in progress

  • Planned
    May 03, 2022 at 7:00:00 PM GMT+00:00

    We are planning for a scheduled maintenance for BCC Password Self Service.