Completed
Citrix Maintenance

Status
Resolved after about 16 hours
Started
June 19, 2022 at 6:00:00 PM GMT+00:00
Completed
June 20, 2022 at 10:02:00 AM GMT+00:00
Affects
Core Services
Citrix - BCC Portal
  • Completed
    June 20, 2022 at 10:02:21 AM GMT+00:00

    Maintenance has completed successfully.

  • Planned
    June 19, 2022 at 6:00:00 PM GMT+00:00

    We are planning for Citrix refresh on Sunday 19th June @ 7pm.