Completed
Citrix Maintenance

Status
Resolved after about 5 hours
Started
June 24, 2022 at 6:00:00 PM GMT+00:00
Completed
June 24, 2022 at 11:00:00 PM GMT+00:00
Affects
Core Services
Citrix - BCC Portal
  • Update
    June 24, 2022 at 11:00:00 PM GMT+00:00

    Maintenance has completed successfully

  • Completed
    June 24, 2022 at 11:00:00 PM GMT+00:00

    Maintenance has completed successfully

  • In progress
    June 24, 2022 at 6:00:01 PM GMT+00:00

    Maintenance is now in progress

  • Planned
    June 24, 2022 at 6:00:00 PM GMT+00:00

    We are planning for a Citrix refresh on the 24th June @ 7pm.