Completed
Self Service Upgrade

Status
Resolved after about 2 hours
Started
July 15, 2022 at 7:00:00 PM GMT+00:00
Completed
July 15, 2022 at 9:00:00 PM GMT+00:00
Affects
Core Services
BCC Password Self Service
Research Services
Labarchives
  • Completed
    July 15, 2022 at 9:00:00 PM GMT+00:00

    Maintenance has completed successfully

  • In progress
    July 15, 2022 at 7:00:01 PM GMT+00:00

    Maintenance is now in progress

  • Planned
    July 15, 2022 at 7:00:00 PM GMT+00:00

    We are planning scheduled maintenance for Self Service.