All systems operational

Citrix Incident - Investigating

Resolved
Operational
Started over 1 year ago Lasted 31 minutes

Affected

Core Services
Citrix - BCC Portal
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    We are continuing to monitor the issue -and should be operational now

  • Investigating
    Investigating

    We are currently investigating this incident.