All systems operational

Filecloud Access in Citrix

Resolved
Operational
Started over 1 year ago Lasted 5 days

Affected

Core Services
Citrix - BCC Portal
Updates
  • Resolved
    Update

    We just resolved the issue!

  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Update

    We implemented a fix and currently monitoring the result.

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.