All systems operational

System Outage

Resolved
Operational
Started almost 2 years ago Lasted 23 minutes

Affected

Core Services
BCC IT Webhelpdesk
BCC Password Self Service
BCInet
Citrix - BCC Portal
MSSQL Servers
Updates
  • Resolved
    Update

    Dell technical support have now resolved the issues affecting connectivity. Access to services has been restored.

    The network will be actively monitored for the next 24 hours.

  • Resolved
    Update

    Access to services have been restored.

  • Resolved
    Resolved

    Fully resolved

  • Identified
    Identified

    Dell Support are actively working to restore services. We will send progress update at 17:00.

  • Investigating
    Investigating

    We are currently investigating an networking incident that is affecting access to a large number of services.